Tag and pulse outcome in SG server

Hello, I am preparing a RPI3 with the latest version of the SG to do manual tracking. Ideally, I want to see if I have detected one of my lost tags in a remote area. I am conducting some trials and I currently can see the information (timeunix, tag, pulse, freq…) in “Radios / Tag and Pulses.” However, when I decode the timeunix value, I get the actual day and minutes but with an 8-hour offset. The UTC time displayed in the top right of the page is correct, and the time in the graphs is also correct. However, the time in the Tag and Pulses board is not accurate.

Example of what I just detected:
TAG: L4,1716886134.9212,492#12@150.1:13.1,3.838,0.00319,-39.8,2.5,-63.6,87,58,9.99e-05,-4.96e-05,150.1

Real time in Spain: 10:49:00
UTC DateTime (top right): 2024-05-28 08:49:30 UTC

Is that possible? Any explanation?
Thank you

@Helena_Navalpotro1 – I can’t reply to your post, the forum doesn’t let me, so replying here…

When I convert the value I get the appropriate UTC time:

> date -u -d '@1716886134'
Tue May 28 08:48:54 AM UTC 2024

How are you doing the conversion?

BTW, for your application I would recommend upgrading to the latest dev snapshot. There are a number of fixes for the charts and you also get SNR more clearly. Plus, instead of unix timestamps it prints the current time. See the post on release trains for info and I highly recommend to toggle the release train to stable after you’re done with the upgrade.

1 Like

Hi Thorsten,
Thank you for your reply. I did what you mentioned: Check, Upgrade and Realese Train, then stable again. But nothing has changed…
I converted the time using chatGTP… I don’t know why it is wrong.

That is what I see

Do I have to restart or reboot after: Enable Buttons → Check → SG Upgrade → Release train ?

Now its like:

But in the Radio nothing has changed:

Hello again,
Now the Funcube is not detected… Is it releated to the Release train?
Thank you

It is again detecting. I have connected the RPI to the wall power and now its working correctly again.

It’s possible the connection is loose. And occasionally the dongle isn’t recognized immediately or there is a lag between when it’s reflected on the interface. That’s particularly true of the lower dongle-related section (port mapping); the section you took a screenshot of typically updates quite quickly and accurately – at least in my experience. Either way, unlugging/plugging it back in may do the trick, or rebooting the the SG may resolve it.


Is yours SG-29CCRPI3DDC7? If so, there was a problem fetching the repository indexes. You can also see it in your screen shots where in the upgrade log there are lines like

W: Failed to fetch https://sensorgnome.s3.amazonaws.com/dists/testing/InRelease  Temporary failure resolving 'sensorgnome.s3.amazonaws.com'

Please ensure you have a good internet connection and try again. If you see the same type of errors try the check or sg-update again. I hope this helps!

Thank you Thorsten, I went to a place with better internet connection and I succeed.
That is what I see now!

And the Radio looks like:

1 Like

Looks great! I hope this works for you.
In case you have not noticed, you can make most of the panels full-page with the little two-arrow icon in the upper-right, I find this particularly helpful for the Tags and Pulses panel when using a phone to watch what’s happening.
Let me know if you need further help or encounter issues!