No Internet Access on SensorGnome V2 Install

Hi everyone,

I’m doing a test install of the V2 software (sg-armv7-rpi-2.0-rc13.zip) on a Raspberry Pi 4B 2GB board, with a Sixfab LTE header board (but without the SIM card yet, because I wanted to make sure of the rest of the functionality first).

We already have ten or so off-grid V1 installations running.

I’m having a couple of problems, starting with no internet access via either WiFi or wired Ethernet.

Both the WiFi and wired connection are to my home network router (an Archer VR1600v) which has a number of other PCs and devices connected via WiFi. The only thing that seems to be failing is external address resolution on the Raspberry Pi. Specifically:

  • The DHCP is working, as both the WiFi and wired connections get dynamic address leases successfully;
  • The captive WiFi hotspot is working, since I can get to the webpage without any problems. The network status page reports the correct values for the DNS and gateway addresses (the network router), and either “eth” or “wifi” for “internet via”, but an “ERR” for the internet access.
  • The Raspberry Pi console doesn’t show any network errors in the startup status, and the dnsmasq daemon is running. I can ping the router and other devices on the network successfully, but I can’t ping any external servers (such as public DNSs). $netstat and $route values look okay.
  • Pinging the same external addresses from a Windows 10 command console works without any problems.

Just in case I had made a mistake with the installation sequence at some point, I re-imaged the Raspberry Pi SD card, but the problems persisted. I fiddled around a little bit with the dnsmasq.conf and resolv.conf configurations, but with no success, and I didn’t want to risk compromising the captive portal setup by not knowing what I was doing.

To my uneducated eye, it looks as if there’s a problem with the gateway routing at either the Raspberry Pi end or my on local network box, but I can’t think what it might be. I’ve gone through all the security settings on the network router (I had to add the WIFi MAC address to the whitelist anyway), but nothing looks relevant.

All suggestions for further troubleshooting would be gratefully accepted, and thank you in advance for your help :).

Regards
Andrew Hide

Hi everyone,

I figured it out - when I went back and double-checked everything again, I’d made a transcription error in the MAC addresses on the Raspberry Pi. Internet access is now working (so on to the next problem :) ).

Regards
Andrew Hide

I’m glad you managed to work it out. Just to recap: the SGv2 does not support ‘captive portals’, e.g. WiFi where you have to visit some page and click on an agreement button or sign in to get full internet access. Sounds like you entered the SG’s MAC address directly into the captive portal router to white-list it. Perfect!
On the network tab the SG web interface does show network status. I would assume that the “motus.org” status was not “OK” before you fixed your issue. The “internet status” may have shown OK or not, it depends a bit on what the captive portal fakes…

Let me know if you have issues with that LTE hat.

Thorsten