4G dongle for internet connection SensorStation

Hi people,

For testing purposes, it’d be convenient to be able to use a 4G dongle to connect a SensorStation (V3.2) to the internet. We happen to have an Alcatel LinkKey IK41VE1 in the office, so I’ve been trying to get it to work with the SensorStation.

The dongle works properly when connected to my Windows 10 laptop. However, it does not show up in any way on the SensorStation. It cannot be found under Network → Ip Address (I have been able to get both ethernet and wifi connection to the SensorStation, and they show up properly as wlan0 and eth0 addresses). It also does not show up on the devices list on the SensorGnome interface. Additionally, connecting the dongle sometimes causes the LCD menu to become irresponsive to the menu navigation buttons, essentially freezing the menu.

I’ve read in other threads that, with the Raspberry pi being a Linux-based system, it might not always be possible to connect arbitrary dongles in the way I’ve been trying. Would it be better to give up on using the dongle I have, and look into other dongles that are known to function with the SensorStation?

Edit: looking into the SensorStation, it appears that there’s an option for an LTE modem. The ones we’ve got don’t have such modems (deliberate or not), that’s why I’m trying to work out a connection to an external 4G dongle.

Lynn, I was hoping someone with more SensorStation experience would chime in. Looking at the code it seems that the SensorStation cellular functionality is pretty tied to the specific Quectel modem they use. But it also looks like ModemManager is running, so that’s a first step if you’re comfortable using the CLI (SSH into the SS).

The first step to check whether the cell modem appears on the USB bus: lsusb should show something recognizable. You can also check whether ModemManager sees it: mmcli -L. If it does, get the details: mmcli -m 0 (replace 0 by the modem number at the end of the path shown by the previous command).

To list the network devices: ip addr and you should see wwan0 or eth1. To establish a connection use something like: mmcli -m 0 --simple-connect.

Good luck and please report back if you’d like more help.

(I can’t recommend going down this route for a permanent install but it can be handy for testing.)

Hi Thorsten, thanks for the help!

The dongle does show up on the list generated by lsusb. The ModemManager cannot find it, however. mmcli -L results in a No modems were found message. I’m looking into it now. If I find a solution, I’ll post it here.

1 Like

What’s the lsusb output?

ctt@sensorstation:~ $ lsusb
Bus 001 Device 013: ID 1bbb:0908 T & A Mobile Phones Mobilebroadband
Bus 001 Device 009: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter
Bus 001 Device 008: ID 239a:800c Adafruit Feather 32u4
Bus 001 Device 007: ID 239a:800c Adafruit Feather 32u4
Bus 001 Device 006: ID 239a:800c Adafruit Feather 32u4
Bus 001 Device 005: ID 239a:800c Adafruit Feather 32u4
Bus 001 Device 004: ID 239a:800c Adafruit Feather 32u4
Bus 001 Device 003: ID 0424:2507 Microchip Technology, Inc. (formerly SMSC) hub
Bus 001 Device 011: ID 0bda:8152 Realtek Semiconductor Corp. RTL8152 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:2507 Microchip Technology, Inc. (formerly SMSC) hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Where device 013 should be the dongle

According to Integrating the Alcatel IK41 seri... | FAQ | Support | Techship the dongle should be workable. You can check dmesg to ensure you’re seeing the output shown in that article. You want the MBIM mode as described in the article and then ModemManager should be able to make it work. If it’s in RNDIS mode (not sure how to determine that) you need some google-fu to find out how to switch it…

I’m not finding a lot of info about “1bbb:0908” but one possibility is that it comes up in CDROM mode, which is basically looking like a drive for Windows with the drivers. If that’s the case there is a linux utility called usb-modeswitch that needs to be used to switch it to act as a modem. I haven’t dealt with this before…

For what it’s worth, this is the tail end of the dmesg output:

[ 346.302290] usb 1-1.7: new high-speed USB device number 12 using dwc_otg
[ 346.444366] usb 1-1.7: New USB device found, idVendor=1bbb, idProduct=025e, bcdDevice=10.00
[ 346.444400] usb 1-1.7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 346.444495] usb 1-1.7: Product: Mobilebroadband
[ 346.444507] usb 1-1.7: Manufacturer: Alcatel
[ 346.444517] usb 1-1.7: SerialNumber: 1234567890ABCDEF
[ 346.446891] usb-storage 1-1.7:1.0: USB Mass Storage device detected
[ 346.447760] scsi host0: usb-storage 1-1.7:1.0
[ 346.638610] usbcore: registered new interface driver uas
[ 347.366072] dwc_otg: DEVICE:012 : update_urb_state_xfer_comp:751:trimming xfer length
[ 347.533928] usb 1-1.7: USB disconnect, device number 12
[ 348.352117] usb 1-1.7: new high-speed USB device number 13 using dwc_otg
[ 348.494104] usb 1-1.7: New USB device found, idVendor=1bbb, idProduct=0908, bcdDevice= 2.42
[ 348.494128] usb 1-1.7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 348.494137] usb 1-1.7: Product: Mobilebroadband
[ 348.494143] usb 1-1.7: Manufacturer: Alcatel
[ 348.494149] usb 1-1.7: SerialNumber: 1234567890ABCDEF
[ 348.499718] cdc_ether 1-1.7:1.0 usb0: register ‘cdc_ether’ at usb-3f980000.usb-1.7, CDC Ethernet Device, 26:21:8c:2f:50:24
[ 348.501231] usb-storage 1-1.7:1.2: USB Mass Storage device detected
[ 348.501677] scsi host0: usb-storage 1-1.7:1.2
[ 349.534279] scsi 0:0:0:0: Direct-Access ONETOUCH MobileBroadBand 2.31 PQ: 0 ANSI: 2
[ 349.537264] sd 0:0:0:0: Power-on or device reset occurred
[ 349.540249] sd 0:0:0:0: [sda] Media removed, stopped polling
[ 349.542105] sd 0:0:0:0: [sda] Attached SCSI removable disk
[ 349.581865] sd 0:0:0:0: Attached scsi generic sg0 type 0

To my (untrained) eye it seems like it detects the dongle, then disconnects it, and then detects it again using different settings.

1 Like

Looks like it. You are getting a cdc_ether interface which should show as usb0 in ip addr. This is one of the ways modems show up. I’m not understanding why ModemManager isn’t seeing it. But it’s looking like I’m hitting end-of-day here…

Some quick notes: if you have a usb0 interface then it acts like a usb-ethernet dongle and the modem act as the router at the other end. Two things need to happen: it needs to “dial” to connect to the cell network, that’s where ModemManager comes in. Then the network stack needs to be hooked up (getting an IP address and setting up routes), I’m pretty sure that should happen using DHCP (e.g. dhcpcd). ip routes shows routes and you should at that point see a default route using usb0. I believe both steps are independent, so you can end up with the routes but packets don’t go anywhere 'cause it hasn’t dialed and connected yet. Posting command output and log snippets helps troubleshooting if you don’t get it to work…